How to fix problem with the editor ‘vi’

10 sec read

:: git error with vi

error: There was a problem with the editor 'vi'

 

:: how to fix the problem
0. check path for vim

$ which vim
/usr/local/bin/vim

1. set core.editor to vim in git

$ git config --global core.editor /usr/local/bin/vim

:: links
+ Google
+ Tooky

Apache :: MP4 Streaming

:: How to Enable mp4 Streaming in Apache + Installing mod h624 streaming wget //h264.code-shop.com/download/apache_mod_h264_streaming-2.2.7.tar.gz tar -xzf apache_mod_h264_streaming-2.2.7.tar.gz cd mod_h264_streaming-2.2.7/ ./configure --with-apxs=`which apxs2` make...
Sysadmin.ID
18 sec read

Apache :: Flash / FLV Streaming

:: How to Configure Apache for FLV Streaming + Installing mod_flvx wget //people.apache.org/~pquerna/modules/mod_flvx.c which apxs /usr/bin/apxs /usr/bin/apxs -cia mod_flvx.c + setup mod_flvx in http.conf...
Sysadmin.ID
15 sec read

Ubuntu :: PHP FastCGI + NGINX

:: How to setup PHP FastCGI for NGINX in Ubuntu + Installing NGINX and php-cgi apt-get update apt-get install nginx php5-cli php5-cgi spawn-fcgi +...
Sysadmin.ID
1 min read

Leave a Reply

Your email address will not be published. Required fields are marked *